// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\d{4}-){3}\d{4}|\d{16}").unwrap();
let string = "5123-4567-8912-3456
61234-567-8912-3456
4123356789123456
5133-3367-8912-3456
6124-56378912-3456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}