import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\d{4}-){3}\\d{4}|\\d{16}";
final String string = "5123-4567-8912-3456\n"
+ "61234-567-8912-3456\n"
+ "4123356789123456\n"
+ "5133-3367-8912-3456\n"
+ "6124-56378912-3456";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}