import re
regex = re.compile(r"(\d),(?=\d)", flags=re.MULTILINE)
test_str = "apple with make,up things $312,412,3.00"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)