re = /(\d),(?=\d)/m
str = 'apple with make,up things $312,412,3.00'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result