package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?|(the) (fair)|(a) (trader)|(offer) (you))\b`)
var str = `If you are going to the fair a trader there will offer you a fair price`
var substitution = "$1_$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}