re = /\b(?|(the) (fair)|(a) (trader)|(offer) (you))\b/m
str = 'If you are going to the fair a trader there will offer you a fair price'
subst = '$1_$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result