$re = '/\b(?|(the) (fair)|(a) (trader)|(offer) (you))\b/m';
$str = 'If you are going to the fair a trader there will offer you a fair price';
$subst = "$1_$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;