import Foundation
let pattern = #"\b(?|(the) (fair)|(a) (trader)|(offer) (you))\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"If you are going to the fair a trader there will offer you a fair price"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)