#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)var\(.+?\)"
Local $sString = "<div data-color="var(--secondary)" data-color-end="var(--brand-primary)">" & @CRLF & _
"<span class="icon icon__centered">" & @CRLF & _
"<i class="fal fa-paper-plane" aria-hidden="true"></i>" & @CRLF & _
"</span>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")