using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"var\(.+?\)";
string input = @"<div data-color=""var(--secondary)"" data-color-end=""var(--brand-primary)"">
<span class=""icon icon__centered"">
<i class=""fal fa-paper-plane"" aria-hidden=""true""></i>
</span>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}