re = /var\(.+?\)/m
str = '<div data-color="var(--secondary)" data-color-end="var(--brand-primary)">
<span class="icon icon__centered">
<i class="fal fa-paper-plane" aria-hidden="true"></i>
</span>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end