$re = '/var\(.+?\)/m';
$str = '<div data-color="var(--secondary)" data-color-end="var(--brand-primary)">
<span class="icon icon__centered">
<i class="fal fa-paper-plane" aria-hidden="true"></i>
</span>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);