#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\textbf({([^{}]*+(?:(?1)[^{}]*)*+)})"
Local $sString = "\textbf{adadasas}" & @CRLF & _
"" & @CRLF & _
"\textbf{adadasas \textit{xxx} adasda {xxx}}" & @CRLF & _
"" & @CRLF & _
"\textbf{adadasas {} {} {} dxxxx}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")