$re = '/\\\\textbf({([^{}]*+(?:(?1)[^{}]*)*+)})/m';
$str = '\\textbf{adadasas}
\\textbf{adadasas \\textit{xxx} adasda {xxx}}
\\textbf{adadasas {} {} {} dxxxx}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);