re = /\\textbf({([^{}]*+(?:(?1)[^{}]*)*+)})/m
str = '\\textbf{adadasas}
\\textbf{adadasas \\textit{xxx} adasda {xxx}}
\\textbf{adadasas {} {} {} dxxxx}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end