using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\textbf({([^{}]*+(?:(?1)[^{}]*)*+)})";
string input = @"\textbf{adadasas}
\textbf{adadasas \textit{xxx} adasda {xxx}}
\textbf{adadasas {} {} {} dxxxx}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}