using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"node_modules\/(?!(react-native|my-project|react-native-button)\/)";
string input = @"what/react-native/
node_modules/react-nati
foobaz";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}