import re
regex = re.compile(r"node_modules\/(?!(react-native|my-project|react-native-button)\/)")
test_str = ("what/react-native/\n"
"node_modules/react-nati\n"
"foobaz")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")