$re = '/node_modules\/(?!(react-native|my-project|react-native-button)\/)/';
$str = 'what/react-native/
node_modules/react-nati
foobaz';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);