const regex = /node_modules\/(?!(react-native|my-project|react-native-button)\/)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('node_modules\\\/(?!(react-native|my-project|react-native-button)\\\/)', '')
const str = `what/react-native/
node_modules/react-nati
foobaz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}