using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(.*?[a-zA-Z]+.*?)\}";
string input = @"Hello_mister,_Hello
{ Jack }
ASD___asdfffasd
{this}{exam}{problem}{is}{boring}
Whatsup_ddd_sup
{Dude}
HeypalHey______how_ya_how_doin_how
{first}{second}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}