import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/year=2020\\/month=06\\/day=(24/\\hour=((1[5-9])|(2[0-3]))|25\\/hour=((0[0-9])|(1[0-9])|20))";
final String string = "--surrounding data\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=08\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=09\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=10\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=11\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=12\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=13\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=14\n\n"
+ "--start matching\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=15\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=16\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=17\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=18\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=19\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=20\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=21\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=22\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=23\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=00\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=01\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=02\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=03\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=04\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=05\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=06\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=07\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=08\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=09\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=10\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=11\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=12\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=13\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=14\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=15\n"
+ "--stop matching\n\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=16\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=17\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=18\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=19\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=20\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=21\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=22\n"
+ "silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=23\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}