# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/year=2020\/month=06\/day=(24/\hour=((1[5-9])|(2[0-3]))|25\/hour=((0[0-9])|(1[0-9])|20))"
test_str = ("--surrounding data\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=08\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=09\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=10\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=11\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=12\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=13\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=14\n\n"
"--start matching\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=15\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=16\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=17\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=18\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=19\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=20\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=21\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=22\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=23\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=00\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=01\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=02\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=03\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=04\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=05\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=06\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=07\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=08\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=09\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=10\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=11\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=12\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=13\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=14\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=15\n"
"--stop matching\n\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=16\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=17\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=18\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=19\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=20\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=21\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=22\n"
"silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=23\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.