const regex = new RegExp('\\/year=2020\\/month=06\\/day=(24/\\hour=((1[5-9])|(2[0-3]))|25\\/hour=((0[0-9])|(1[0-9])|20))', 'g')
const str = `--surrounding data
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=08
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=09
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=10
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=11
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=12
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=13
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=14
--start matching
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=15
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=16
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=17
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=18
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=19
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=20
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=21
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=22
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=23
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=00
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=01
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=02
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=03
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=04
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=05
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=06
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=07
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=08
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=09
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=10
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=11
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=12
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=13
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=14
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=15
--stop matching
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=16
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=17
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=18
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=19
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=20
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=21
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=22
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=23
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}