use strict;
my $str = '--surrounding data
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=08
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=09
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=10
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=11
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=12
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=13
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=14
--start matching
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=15
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=16
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=17
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=18
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=19
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=20
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=21
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=22
silver/power/minute/monitor_id=10817/year=2020/month=06/day=24/hour=23
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=00
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=01
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=02
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=03
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=04
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=05
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=06
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=07
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=08
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=09
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=10
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=11
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=12
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=13
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=14
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=15
--stop matching
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=16
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=17
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=18
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=19
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=20
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=21
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=22
silver/power/minute/monitor_id=10817/year=2020/month=06/day=25/hour=23
';
my $regex = qr/\/year=2020\/month=06\/day=(24/\hour=((1[5-9])|(2[0-3]))|25\/hour=((0[0-9])|(1[0-9])|20))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}