using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\w\n]+(\w)";
string substitution = @"\U$1";
string input = @"hello ladies how are you Today
I am fine thank you";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}