const regex = /[^\w\n]+(\w)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\w\\n]+(\\w)', 'g')
const str = `hello ladies how are you Today
I am fine thank you`;
const subst = `\U$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);