re = /[^\w\n]+(\w)/
str = 'hello ladies how are you Today
I am fine thank you'
subst = '\\U$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result