#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z].*(?:\n+[a-zA-Z].*)*(?=\n+\d{6,}$)"
Local $sString = "27223525" & @CRLF & _
"" & @CRLF & _
"West Food Group B.V.9" & @CRLF & _
"" & @CRLF & _
"52608670" & @CRLF & _
"" & @CRLF & _
"Westcon" & @CRLF & _
"" & @CRLF & _
"Group European Operations Netherlands Branch" & @CRLF & _
"" & @CRLF & _
"30221053" & @CRLF & _
"" & @CRLF & _
"Westland Infra Netbeheer B.V." & @CRLF & _
"" & @CRLF & _
"27176688" & @CRLF & _
"" & @CRLF & _
"Wetransfer 85 B.V." & @CRLF & _
"" & @CRLF & _
"34380998" & @CRLF & _
"" & @CRLF & _
"WETRAVEL B.V." & @CRLF & _
"" & @CRLF & _
"70669783"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")