re = /^[a-zA-Z].*(?:\n+[a-zA-Z].*)*(?=\n+\d{6,}$)/m
str = '27223525
West Food Group B.V.9
52608670
Westcon
Group European Operations Netherlands Branch
30221053
Westland Infra Netbeheer B.V.
27176688
Wetransfer 85 B.V.
34380998
WETRAVEL B.V.
70669783'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end