# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z].*(?:\n+[a-zA-Z].*)*(?=\n+\d{6,}$)"
test_str = ("27223525\n\n"
"West Food Group B.V.9\n\n"
"52608670\n\n"
"Westcon\n\n"
"Group European Operations Netherlands Branch\n\n"
"30221053\n\n"
"Westland Infra Netbeheer B.V.\n\n"
"27176688\n\n"
"Wetransfer 85 B.V.\n\n"
"34380998\n\n"
"WETRAVEL B.V.\n\n"
"70669783")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.