using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(.+?\))\s?\(";
string input = @"""This thing (123, 12) (2005.03 - 2011.12)""
""This thing (2005.03 - 2011.12)""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}