re = /(\(.+?\))\s?\(/
str = '"This thing (123, 12) (2005.03 - 2011.12)"
"This thing (2005.03 - 2011.12)"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end