// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\(.+?\))\s?\(").unwrap();
let string = "\"This thing (123, 12) (2005.03 - 2011.12)\"
\"This thing (2005.03 - 2011.12)\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}