package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\(.+?\))\s?\(`)
var str = `"This thing (123, 12) (2005.03 - 2011.12)"
"This thing (2005.03 - 2011.12)"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}