# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?<![-‑–])(\d+)\s+/\1 /g;t' <<< "123 and -7654 h"