import re
regex = re.compile(r"\b(?<![-‑–])(\d+)\s+")
test_str = "123 and -7654 h"
subst = "\\1 "
result = regex.sub(subst, test_str)
if result:
print(result)