const regex = new RegExp('\\b(?<![-‑–])(\\d+)\\s+', 'g')
const str = `123 and -7654 h`;
const subst = `\1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);