$re = '/\b(?<![-‑–])(\d+)\s+/';
$str = '123 and -7654 h';
$subst = "\1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;