#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!\\)(\{json[ ]+([\s\S]+?)[ ]+\})"
Local $sString = "{json {json } } lorem ipsum {json dolor }"
Local $sSubst = "\g<1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)