re = /(?<!\\)(\{json[ ]+([\s\S]+?)[ ]+\})/
str = '{json {json } } lorem ipsum {json dolor }'
subst = '\\g<1>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result