import re
regex = re.compile(r"(?<!\\)(\{json[ ]+([\s\S]+?)[ ]+\})")
test_str = "{json {json } } lorem ipsum {json dolor }"
subst = "\\g<1>"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)