using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(\{json[ ]+([\s\S]+?)[ ]+\})";
string substitution = @"\g<1>";
string input = @"{json {json } } lorem ipsum {json dolor }";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}