#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+|#+|@+|[^#@\d\n]+"
Local $sString = "image.0001" & @CRLF & _
"image###" & @CRLF & _
"###image###" & @CRLF & _
"image001" & @CRLF & _
"image_001" & @CRLF & _
"001" & @CRLF & _
"0001.image" & @CRLF & _
"001image" & @CRLF & _
"001_image" & @CRLF & _
"image" & @CRLF & _
"01_image01" & @CRLF & _
"03_image01" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")