import re
regex = re.compile(r"\d+|#+|@+|[^#@\d\n]+", flags=re.MULTILINE)
test_str = ("image.0001\n"
"image###\n"
"###image###\n"
"image001\n"
"image_001\n"
"001\n"
"0001.image\n"
"001image\n"
"001_image\n"
"image\n"
"01_image01\n"
"03_image01\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")