re = /\d+|#+|@+|[^#@\d\n]+/m
str = 'image.0001
image###
###image###
image001
image_001
001
0001.image
001image
001_image
image
01_image01
03_image01
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end