using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+|#+|@+|[^#@\d\n]+";
string input = @"image.0001
image###
###image###
image001
image_001
001
0001.image
001image
001_image
image
01_image01
03_image01
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}