#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?=\b(jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec|\d{4}|\d{1,2}))\w*[\t\ \\\/\.\,\;\:\-\+\_]+(\d{1,2}|jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec)\w*[\t\ \\\/\.\,\;\:\-\+\_]+(\d{4}|\d{1,2})\w*\b"
Local $sString = " january 23rd 2011" & @CRLF & _
"2004 / 03 / 12" & @CRLF & _
" 1/12/2014 16-12-04" & @CRLF & _
" feb 18 1970" & @CRLF & _
" 2014.2.24" & @CRLF & _
"12-12-12" & @CRLF & _
"2nd 12 2004" & @CRLF & _
"" & @CRLF & _
"1st Feb 2008" & @CRLF & _
"" & @CRLF & _
"2001-09-11" & @CRLF & _
"2001 Sep 11" & @CRLF & _
"" & @CRLF & _
"sep-jan 2000" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"mar" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")