re = /(?=\b(jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec|\d{4}|\d{1,2}))\w*[\t\ \\\/\.\,\;\:\-\+\_]+(\d{1,2}|jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec)\w*[\t\ \\\/\.\,\;\:\-\+\_]+(\d{4}|\d{1,2})\w*\b/i
str = ' january 23rd 2011
2004 / 03 / 12
1/12/2014 16-12-04
feb 18 1970
2014.2.24
12-12-12
2nd 12 2004
1st Feb 2008
2001-09-11
2001 Sep 11
sep-jan 2000
mar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end