import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\b(jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec|\\d{4}|\\d{1,2}))\\w*[\\t\\ \\\\\\/\\.\\,\\;\\:\\-\\+\\_]+(\\d{1,2}|jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec)\\w*[\\t\\ \\\\\\/\\.\\,\\;\\:\\-\\+\\_]+(\\d{4}|\\d{1,2})\\w*\\b";
final String string = " january 23rd 2011\n"
+ "2004 / 03 / 12\n"
+ " 1/12/2014 16-12-04\n"
+ " feb 18 1970\n"
+ " 2014.2.24\n"
+ "12-12-12\n"
+ "2nd 12 2004\n\n"
+ "1st Feb 2008\n\n"
+ "2001-09-11\n"
+ "2001 Sep 11\n\n"
+ "sep-jan 2000\n\n\n\n"
+ "mar\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}